公告:如果您的账号不能登录,可能是系统对您账号进行了保护,我们发现系统中存在着不安全密码,故对其重置,请您重新激活账号,对于给您造成的不便,敬请谅解!
论坛风格切换切换到宽版
  • 352662阅读
  • 505回复

DedeCMS V5.3正式版升级程序下载(09.1.15更新) [复制链接]

上一主题 下一主题
离线天涯
 

发帖
6019
贡献值
6191
威望值
3539
技术分
0
织梦币
5
只看楼主 倒序阅读 使用道具 0 发表于: 2008-12-10
— 本帖被 dede 执行取消置顶操作(2009-01-12) —
目前已经推出了各个版本的升级程序,请织梦用户下载并进行网站升级。

更新日期: 2009.1.15  

升级程序下载地址:
1.DedeCms V3.1、4.0、4.01升级程序
http://updatenew.dedecms.com/DedeCmsUPV5.3Pack/v3-v4-upToV5.3GBK.zip

2.V5.0、5.1、5.2BIZ  To  5.3.1 升级包:
GBK版
http://updatenew.dedecms.com/DedeCmsUPV5.3Pack/v5.1-gbk-up5.3.1.zip
UTF8版
http://updatenew.dedecms.com/DedeCmsUPV5.3Pack/v5.1-utf8-up5.3.1.zip

3.V5.3 To 5.3.1 升级包:
http://updatenew.dedecms.com/Patch/DedeCmsV5.3.1-Update.zip
由于此次更新比较特殊,不支持通过在线升级进行升级,安装了UC的用户注意阅读说明:
[1]、即普通用户升级流程:
替换文件  ->  运行 http://你的网址/update.php -> 完成升级
[2]、安装了UC用户的升级流程:
替换文件  ->  运行 http://你的网址/update.php -> 用UC文件夹文件再次替换文件 -> 完成升级

由于目录的相应的程序还不完全,因此暂时只给出相应该的文件列表目录,如果有更新,也按目录列表的时间为准。

升级注意问题:
一、我应该使用哪个升级包?
v5.1-gbk-up5.3.zip
适用: DedeCms V5.01、DedeCms V5.1GBK、DedeCms V5.1sp1 GBK

v5.1-utf8-up5.3.zip
适用:DedeCms V5.01、DedeCms V5.1UTF8、DedeCms V5.1sp1 UTF8

v3-v4-upToV5.3GBK.zip
适用:DedeCms V3.1, DedeCms V4.0, DedeCms V4.01

二、升级可能会出现的问题:

1、由于V5.3 Base版本专门针对中小型资讯门户设计,因此取消了原来指定管理员管理指定多个栏目的权限,升级后会统一为不限制或选择单个顶级栏目(高级版本用新的权限系统也不兼容旧版);

2、会员中心作了全面升级,因此除了会员登录数据作保留外,其它一些数据一般会被清空或不完全转换;

3、分类信息模型与旧模型数据及模板不完全兼容;

4、栏目中的单独页会被取消;

5、自定义属性会有一部份受到影响。

6、自定义模型可能会有一部份受到影响,如果你的系统主要使用自定义模型,建议不要升级或升级商业服务。

7、原来的模板可能存在个别的不兼容。

8、本升级程序只适用于 DedeCms V5.1或 5.1sp1的升级,5.0或5.0.1版请用其它升级程序。

9、由于V5.3使用了更科学的单字段实现双重地区与行业索引结构,因此旧版的地区与行业数据会丢失。

10、由于V5.3管理员使用密码方式不同,因此旧的管理帐号密码必须重设。

11、升级程序有风险,升级前建议先做好数据备份工作,否则带来数据损失本司不负任何责任。

升级说明
由于DedeCms V5.3内核进行了全面升级,因此旧版的所的程序文件在新版中都是不兼容的

在升级前请先进行下面操作:

1、备份好您的数据,以防止升级时发生偶然因素导致失败,从而整个网站损坏;建议在副本上进行升级测试;

2、把网站上除了附件及HTML文件存放目录以外的目录及文件都删除

3、完成上述准备后,把 upload 文件夹里的全部文件上传到需升级的网站

然后运行  http://网址/install/index.php 进行升级

4、还原你的模板
(注意:原系统的“顶”功能将不可用,请自行更换为新版的代码、模板标记里如果带有function的,可能会存在不兼容[如果自定义模型里无法显示文档很可能是这个原因导致])
模板标签基本向老版本兼容,如果存在标签上面的使用问题,可以参考织梦的帮助中心关于模板标签方面的说明。

5、旧版的分类信息程序将不可用

6、旧版的黄页里的地区和行业信息将会丢失

7、如果你旧版的会员使用的是非标准md5密码的,升级后的会员数据将无法使用

8、如果你的系统原来没有安装圈子、黄页、问答、连载这些模块,你不管是否使用,在升级完成后必须在模块管理的地方御载一次。

相关整合程序
浏览: 
 http://updatenew.dedecms.com/DedeCmsV5.3Module/
目录可获得相关整合包(整合包为XML格式,需要在后台模块管理的地方上传,然后安装)
[ 此帖被木耳在2009-02-02 11:06重新编辑 ]
5条评分
ali 威望值 +5 支持dede! 2008-12-10
defans 威望值 +1 希望能把整合做的完善一些 2008-12-10
天伤雨默 威望值 +1 其实我想扣分的 2008-12-10
peixun 威望值 +1 我也想扣分 2008-12-10
木耳 威望值 +10 很详细 2008-12-10
评价一下你浏览此帖子的感受

支持下

愤怒

哥笑了

优秀

飘过
离线chinafu1

发帖
3377
贡献值
2206
威望值
456
技术分
0
织梦币
0
只看该作者 1 发表于: 2008-12-10
  
:)-支持DEDE
祝DEDE越来越强大
 
离线tonglanjie
发帖
226
贡献值
4
威望值
99
技术分
0
织梦币
0
只看该作者 2 发表于: 2008-12-10
我要先回贴就好了 可惜我是先看的贴....


差点第一楼



晕.....开发.......
 
源码网络 www.codewl.cn  友情连接加我QQ:332801349
离线5120w

发帖
115
贡献值
6
威望值
15
技术分
0
织梦币
0
只看该作者 3 发表于: 2008-12-10
快点啊·~等不急了·~~~支持织梦,哈哈
离线10867
发帖
107
贡献值
1
威望值
64
技术分
0
织梦币
0
只看该作者 4 发表于: 2008-12-10
顶........................
离线chinafu1

发帖
3377
贡献值
2206
威望值
456
技术分
0
织梦币
0
只看该作者 5 发表于: 2008-12-10
PHPWind通行证、UCenter接口的开发
这是站长的福音啊
离线yboy
发帖
191
贡献值
0
威望值
92
技术分
0
织梦币
0
只看该作者 6 发表于: 2008-12-10
很好很强大
潮人街 - 提升穿衣品味 chaorenjie.cn
离线玩家

发帖
2565
贡献值
64
威望值
1049
技术分
0
织梦币
0
只看该作者 7 发表于: 2008-12-10
支持。。
离线w318

发帖
230
贡献值
8
威望值
79
技术分
0
织梦币
0
只看该作者 8 发表于: 2008-12-10
好像还在第一页
给力学习网 www.glxuexi.com 让你学习更给力!
离线echo_mb
发帖
70
贡献值
20
威望值
34
技术分
0
织梦币
0
只看该作者 9 发表于: 2008-12-10
呵呵,强啊,希望能在12号DZ发布时就能用上,整合的功能